Welcome to the world of Saab ! Register
  • Tweek's Turbos

    There is no available content written by Tweek's Turbos
  • Google Ads



  • Events

  • Latest Forum Posts

    Digger

    2003 9-3 no sound, radio doesn't start, NOT APM1, ECU, or ICM2

    While you have a Tech 2 hooked in General Diagnostics is always a good idea. For your problem reset and test the BUS line, both I and O. Make sure that

    Digger 9 Hours Ago Go to last post
    sillysaabowner

    AC problems

    Quick question to make sure we have the correct relay as we check with a multimeter and we did get 12.8 volts at relay location and at the wiring harness

    sillysaabowner 9 Hours Ago Go to last post
    sillysaabowner

    AC problems

    Hi there and happy almost Memorial Day. Thanks for your reply, greatly appreciated. That makes more sense, acc =accessories ok dumb blonde moment lol!

    sillysaabowner 10 Hours Ago Go to last post
    mcmillco

    2003 9-3 no sound, radio doesn't start, NOT APM1, ECU, or ICM2

    Thanks, you are right that the pieces could be bad. I made a fiber optic bypass and swapped out the amps again. Still nothing. I tried every combination

    mcmillco 13 Hours Ago Go to last post
    Digger

    AC problems

    About 20 years ago I spent several days pulling upholstery, panels and carpet included, looking at every inch of the wiring harness inside the car for

    Digger 15 Hours Ago Go to last post
  • Facebook

  • Amazon

All times are GMT. The time now is 09:14.
Powered by vBulletin® Version 4.2.5
Copyright © 2019 vBulletin Solutions Inc. All rights reserved.