Welcome to the world of Saab ! Register
  • johnnymac

    There is no available content written by johnnymac
  • Google Ads



  • Events

  • Latest Forum Posts

    mcmillco

    2003 9-3 no sound, radio doesn't start, NOT APM1, ECU, or ICM2

    Thanks, you are right that the pieces could be bad. I made a fiber optic bypass and swapped out the amps again. Still nothing. I tried every combination

    mcmillco 3 Hours Ago Go to last post
    Digger

    AC problems

    About 20 years ago I spent several days pulling upholstery, panels and carpet included, looking at every inch of the wiring harness inside the car for

    Digger 4 Hours Ago Go to last post
    sillysaabowner

    AC problems

    The saga continues...so crazy idea and maybe someone here will know. The 15a fuse in the drivers side door slot 20 is for the acc/rear fog lights/interior

    sillysaabowner 6 Hours Ago Go to last post
    Mike Brennan

    0730 Gear Code on and then off???

    Transmission is shot. Found one with 66000 miles in New Jersey. 4th gear band is gone. Scoped and tested by a transmission expert in Escanaba. He

    Mike Brennan 1 Day Ago Go to last post
    Digger

    2003 9-3 no sound, radio doesn't start, NOT APM1, ECU, or ICM2

    Just because you replaced the amp doesn't mean you replaced it with a good one. As you now have 2 amp 1's might as well ruin one to find out if you have

    Digger 2 Days Ago Go to last post
  • Facebook

  • Amazon

All times are GMT. The time now is 23:11.
Powered by vBulletin® Version 4.2.5
Copyright © 2019 vBulletin Solutions Inc. All rights reserved.