Welcome to the world of Saab ! Register

Search:

Type: Posts; Posts From Last Day

Search: Search took 0.09 seconds.

  1. The threads below have not been updated since your last visit or since forums have been marked read.
  2. Challenging mind teaser with my 2001 9-3

    Started by tee_kei, 1 Week Ago 06:15
    • Replies: 3
    • Views: 61
    Last Post: 41 Minutes Ago 17:10
    by avid0g  Go to last post
    • Replies: 3
    • Views: 4,691
    Last Post: 2 Hours Ago 15:49
    by avid0g  Go to last post
    • Replies: 8
    • Views: 4,047
    Last Post: 2 Hours Ago 15:36
    by avid0g  Go to last post
  3. Power steering leak at the reservoir cap

    Started by 100%Saab, 1 Week Ago 02:26
    • Replies: 2
    • Views: 97
    Last Post: 2 Hours Ago 15:18
    by avid0g  Go to last post
  4. Bad idea to take apart tail light?

    Started by ksamas, 3 Weeks Ago 22:48
    turbo6 2011 tail light
    • Replies: 2
    • Views: 153
    Last Post: 2 Hours Ago 15:06
    by avid0g  Go to last post
  5. Outside Air Temperature sensor replacement

    Started by GeoffR, 06 November 2017 18:55
    • Replies: 1
    • Views: 248
    Last Post: 2 Hours Ago 14:56
    by avid0g  Go to last post
  6. Faulty Coolant Temperature Sensor

    Started by 100%Saab, 1 Week Ago 23:07
    • Replies: 1
    • Views: 60
    Last Post: 3 Hours Ago 14:47
    by avid0g  Go to last post
  7. 93 aero wont start 2004

    Started by tenthsaab!, 5 Hours Ago 12:00
    93aero, cutting out, start
    • Replies: 0
    • Views: 20
    Last Post: 5 Hours Ago 12:00
    by tenthsaab!  Go to last post
    • Replies: 3
    • Views: 105
    Last Post: 7 Hours Ago 10:44
    by avid0g  Go to last post
  8. DIY - fixing of LED light bar

    Started by radbis, 3 Days Ago 11:48
    • Replies: 7
    • Views: 172
    Last Post: 7 Hours Ago 10:13
    by avid0g  Go to last post
  9. Reverse light not working.

    Started by Lex Andrews, 31 March 2013 01:04
    • Replies: 8
    • Views: 3,058
    Last Post: 7 Hours Ago 09:56
    by avid0g  Go to last post
  10. Burping coolant from overflow tank.

    Started by tonyn007, 1 Week Ago 19:40
    • Replies: 4
    • Views: 125
    Last Post: 8 Hours Ago 09:21
    by avid0g  Go to last post
  11. Vacuum lines and o2 sensor

    Started by Fox Cain, 08 August 2011 01:42
    • Replies: 5
    • Views: 4,495
    Last Post: 9 Hours Ago 07:59
    by avid0g  Go to last post
  12. No Reverse Sensor

    Started by Rognmoe, 10 May 2012 23:01
    • Replies: 1
    • Views: 1,285
    Last Post: 10 Hours Ago 07:49
    by avid0g  Go to last post
  13. Reverse lights not working

    Started by Naizz, 27 August 2017 20:45
    • Replies: 7
    • Views: 507
    Last Post: 10 Hours Ago 07:20
    by avid0g  Go to last post
  14. Reverse lights do not work

    Started by Saabaka, 08 November 2017 10:46
    • Replies: 4
    • Views: 326
    Last Post: 10 Hours Ago 07:11
    by avid0g  Go to last post
Results 1 to 16 of 16
All times are GMT. The time now is 17:52.
Powered by vBulletin® Version 4.2.5
Copyright © 2018 vBulletin Solutions Inc. All rights reserved.