Welcome to the world of Saab ! Register

Search:

Type: Posts; User: MACHETTTTTE

Search: Search took 0.19 seconds.

  1. Replies
    6
    Views
    273

    Do you have a manual transmission? Does the...

    Do you have a manual transmission? Does the symptom occur only in colder weather?
    If yes, I have a similar problem. All it takes for me is to back up 20 cm and than I can shift the gears no...
  2. Replies
    6
    Views
    384

    I also get a 3/4 reading when the tank is full....

    I also get a 3/4 reading when the tank is full.
    I believe the aftermarket fuel pump sender might have a different voltage range than the original one.

    Also, check if the markings are aligned (one...
  3. Replies
    13
    Views
    30,063

    It is pita when you're doing it first time. Now I...

    It is pita when you're doing it first time. Now I do this under 20 minutes. It's a good idea to slide a piece of cardboard between the sponge and the filter during installation, check out this video:...
  4. I'm in the process of changing my oil, only...

    I'm in the process of changing my oil, only approx. 3 liters came out! Out of 4! I'm not a happy bunny.
    I swear the dipstick had oil on it every time I checked. I guess you can't trust that too...
  5. The problem was with the connector mechanism...

    The problem was with the connector mechanism itself, WD-40 really helped to loosen/lubricate the stuck connector. Before applying it I could barely move the black lever upwards.
  6. Thank you for your opinion. This was my first...

    Thank you for your opinion. This was my first thought as well. I'll do an oil change and check the pickup screen with an endoscope to see if it's not clogged. It doesn't sound like the chain or rod...
  7. Engine ticking after driving at higher speeds, e.g. 90 km/h

    Hello,

    recently my 1997 SAAB 9-5 2.0 started generating an engine sound coming from the upper part. This happens only after driving with higher speeds. After a short break the engine sounds normal...
  8. Thanks! Actually, all I had to do was spray some...

    Thanks! Actually, all I had to do was spray some WD-40 on the old connector and leave it overnight. Came off no problem in the morning. Just had to lift the black lever.
  9. Replies
    13
    Views
    30,063

    Hey guys, just wanted to say that I tested the...

    Hey guys, just wanted to say that I tested the Bosch cabin filter and found it difficult to install (took me over 20 min to slide it in place). Last year I bought a MEYLE cabin air filter, part no....
  10. Engine harness connector - problem with disconnecting

    Hello,

    I've stumbled upon a rather silly problem when trying to install new vacuum lines on my 1997 Saab 9-5.
    I don't know how to disconnect the connector shown in the picture. It's placed above...
Results 1 to 10 of 10
All times are GMT. The time now is 22:43.
Powered by vBulletin® Version 4.2.5
Copyright © 2019 vBulletin Solutions Inc. All rights reserved.