Welcome to the world of Saab ! Register
Results 1 to 4 of 4
  1. #1

    Join Date
    01 Jun 2013
    Location
    Cheltenham UK
    Posts
    2
    Saab(s)
    2006 Saab 9-3 Convertible Linear 1.8t
    Thumbs Up:   0

    Unhappy Intermittent Starting Problem

    [FONT=verdana]Hello all, as this is my first thread.

    I have been experiencing an intermittent ignition problem and have read all the existing threads relating to ignition troubles and none seem to match my symptoms.
    So here goes:
    The ignition detects the key fob being put into slot and you hear the steering lock disengage.
    The ignition can then be turned to on etc and most lights seem to power up.
    SID does not return any errors. Check OK.
    The only Lights that do not power up are the Mileage (Odometer) and i panel at bottom of instrument cluster.
    While this panel is not displaying, you can turn the key from ON position to the START position but nothing happens, this has happened twice in two weeks. Then all of a sudden the panel will illuminate and the car starts and runs perfectly.
    This only happens after a startup where they fob is turned and the starter motor cranks for a millisecond then said panel fails to illuminate.
    Have also had the speedo drop to zero and the instrument cluster warning lights randomly flash while travelling, but this does not interfere with the overall performance while occurring.

    My thinking is that it could be the ISM or the ignition relay, but would just like to confirm my thinking, but not sure which controls power to the said cluster.

    Thanking you in advance of you replies.[/FONT]

    0 Not allowed!

  2. #2
    Jeffrey
    Master SaabTech/Moderator Burnsside42's Avatar
    Join Date
    25 Oct 2010
    Location
    South Eastern PA
    Posts
    1,307
    Saab(s)
    - 86' 9KT - 95' 9K Custom CS - 06' 9-3 Sedan - 06' 9-3 Combi - 08' 9-3 TurboX -
    Thumbs Up:   2
    Ignition Switch - ISM

    0 Not allowed!

  3. #3
    Saab Fan
    Join Date
    12 Jul 2012
    Location
    New York, USA
    Posts
    37
    Saab(s)
    06 Saab 9-3 Aero
    Thumbs Up:   0
    Does this problem drain your battery? I think I am having a similar problem with my 2006 93 aero. If I don't run my car every day or 2 my battery drains out and the car can't start. I have already replaced the ISM and that did not solve the problem. Also, I have replaced the battery and the alternator is putting out proper voltage. As it seems with your problem, once the car is on it runs like a champ, however I do not have any failing mileage or i pannel. Something is obviously being left on when the car is turned off, but is definitely not an interior light or anything of that nature. I believe the previous owners had the radio unit replace under warranty due to peeling buttons, maybe while the dash was torn down an electrical problem occurred. Please keep you progress posted!

    0 Not allowed!

  4. #4

    Join Date
    01 Jun 2013
    Location
    Cheltenham UK
    Posts
    2
    Saab(s)
    2006 Saab 9-3 Convertible Linear 1.8t
    Thumbs Up:   0
    [FONT=verdana]Car is not starting now. When you insert fob, you hear steering lock disengage. when you turn fob to on, the only light that illuminates in the instrument cluster, is engine warning light , handbrake, airbag, mileage lights etc are all dead, the SID returns ''check ok'', then when you try to start it, nothing at all happens.[/FONT]
    [FONT=verdana]Have noticed a high pitched noise, that seems to originate behind dash, but it is very faint.[/FONT]
    [FONT=verdana]Any clues, have cleaned the ISM, had RAC out and they got P1616, immobiliser issue. I think its off to Saab we go![/FONT]

    0 Not allowed!

 

 

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
All times are GMT. The time now is 11:24.
Powered by vBulletin® Version 4.2.5
Copyright © 2017 vBulletin Solutions Inc. All rights reserved.