Welcome to the world of Saab ! Register
Results 1 to 3 of 3
  1. #1

    Join Date
    26 Jan 2014
    Location
    Bournemouth, UK
    Posts
    3
    Saab(s)
    2003 9 3 se turbo
    Thumbs Up:   0

    Heater fan

    I have just acquired a saab 9 3, 2003 convertible.
    When I pujt the ignition key in, I get a light rumbling as if the heater fan is goin. Whne I switch the ignition off, this noise goes on for about 10 minutes. Is this normal.
    The hood does not work either, but as it is still raining I haven't got round to this yet.
    Can anyone help with the rumbling noise pleae?
    David

    0 Not allowed!

  2. #2
    Jeffrey
    Master SaabTech/Moderator Burnsside42's Avatar
    Join Date
    25 Oct 2010
    Location
    South Eastern PA
    Posts
    1,308
    Saab(s)
    - 86' 9KT - 95' 9K Custom CS - 06' 9-3 Sedan - 06' 9-3 Combi - 08' 9-3 TurboX -
    Thumbs Up:   2
    It is your in-car cabin temp sensor located by your heated seat switches. You'll see a vented cover over it. Pop that off and remove the seat switches. The sensor pulls out from behind and then through the front. There is a fan inside of this to draw in air - this is what is DIRTY and out of balance. Remove all the hair from it and clean with an electrical contact spray. Add a few drips of oil to the fan posts and re-install. Just like new.

    0 Not allowed!

  3. #3

    Join Date
    26 Jan 2014
    Location
    Bournemouth, UK
    Posts
    3
    Saab(s)
    2003 9 3 se turbo
    Thumbs Up:   0

    temp sensor

    Quote Originally Posted by Burnsside42 View Post
    It is your in-car cabin temp sensor located by your heated seat switches. You'll see a vented cover over it. Pop that off and remove the seat switches. The sensor pulls out from behind and then through the front. There is a fan inside of this to draw in air - this is what is DIRTY and out of balance. Remove all the hair from it and clean with an electrical contact spray. Add a few drips of oil to the fan posts and re-install. Just like new.
    Thankyou so much - took 10 minutes to solve. I assume the fan keeps going for a short while - can't hear it now.
    I now need some help with the soft top. Just comes up with soft failure.
    Rear windows go down a bit, then nothing.
    Any help or advice would be appreciated.
    David

    0 Not allowed!

 

 

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
All times are GMT. The time now is 02:24.
Powered by vBulletin® Version 4.2.5
Copyright © 2018 vBulletin Solutions Inc. All rights reserved.