Welcome to the world of Saab ! Register
Results 1 to 2 of 2
  1. #1

    Join Date
    02 Jan 2015
    Location
    Spojené kráľovstvo
    Posts
    2
    Saab(s)
    93 linear sport 150 HP TID
    Thumbs Up:   0

    TCS light on car doesn't start

    Hi guy's my saab doesn't start at all. If I turn the key to position start dash board coming on as usual just fuel indicator stay on 0 I'm sure I have full tank just last night when I come back to home park my car no issues indicated car was running perfect. Next day when I want to live my home realised this problem. Car don't start. I have checked battery all fuse and relays all of them are ok. The thing is even the fuel pump on the usual start come active and pushing the diesel to the engine. But now doesn't pressuring at all. If I take my key out of the socket the steering wheel is not locked. 4 months ago same issue but car was starting one cable from the main engine relay (red) has oxidation on one case and was not čom unikátom between ecm and fuse box. But the wires was checked all of them and wrapped properly to protect them. Any advice please.
    Thanks

    0 Not allowed!

  2. #2

    Join Date
    02 Jan 2015
    Location
    Spojené kráľovstvo
    Posts
    2
    Saab(s)
    93 linear sport 150 HP TID
    Thumbs Up:   0
    After 2 days car start normal lights off I thing the wires was weet and some of te cables on alternator or starter have blind contact. I will check it.

    0 Not allowed!

 

 

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
All times are GMT. The time now is 04:28.
Powered by vBulletin® Version 4.2.5
Copyright © 2019 vBulletin Solutions Inc. All rights reserved.