Welcome to the world of Saab ! Register
Results 1 to 3 of 3
  1. #1

    Join Date
    15 Sep 2014
    Location
    Nashville
    Posts
    3
    Saab(s)
    1992 900s Convertible
    Thumbs Up:   0

    900 suddenly not starting

    Suddenly my 92 convertible is not starting. It doesn't even attempt to turn over - I turn the key and nothing. I thought it was the battery so I had that tested and confirmed good. I checked the fuse and it is good. I also hear both the relay in the fusebox and the relay under the back seat click when turning the key to start. If I bypass the ignition system by connecting the power directly to the starter, I can get the starter to spin, something I do not hear when turning the ignition so I don't believe it's the starter.

    The only thing I haven't done is get a friend to try to start the car while connecting my multi-meter to the ignition wire to see if power is getting to the starter. I suspect it won't so I'm wondering if anybody has any ideas as to the cause. Even though I hear the relays click, can one of them be bad?

    I have been driving the car on a regular basis, went out to start it one day after it had been sitting for a couple days and this happened.

    0 Not allowed!

  2. #2

    Join Date
    15 Sep 2014
    Location
    Nashville
    Posts
    3
    Saab(s)
    1992 900s Convertible
    Thumbs Up:   0
    Everything else about the power appears to work ok. All the dash board lights, fan, interior lights, radio, etc...

    0 Not allowed!

  3. #3
    Sam Carlson
    Tutorial Bot euromobile900's Avatar
    Join Date
    14 Aug 2010
    Location
    Medford, MA
    Posts
    683
    Saab(s)
    '90 900 LPT with a flat-nose conversion
    Thumbs Up:   2
    You can start by checking the ground wires from the engine to the body. Sometimes these can corrode and cause problems. Power from the ignition switch in the 92 convertible should go via a relay controlled by the burglar alarm to the starter solenoid. Maybe the alarm is messing with things?

    That said, when you tested the starter, did you use the solenoid? Or did you just connect directly to the post with the braided cable going directly into the starter?

    0 Not allowed!
    Ask me a question about your c900! I promise I either can answer it or know someone who can

 

 

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
All times are GMT. The time now is 18:34.
Powered by vBulletin® Version 4.2.5
Copyright © 2020 vBulletin Solutions Inc. All rights reserved.