Welcome to the world of Saab ! Register
Results 1 to 4 of 4
  1. #1
    Saab Enthusiast
    Join Date
    26 Dec 2011
    Location
    Russia
    Posts
    168
    Saab(s)
    88' 9000 2.0i, 05' 9-5 Aero 345HP, 11' 9-4X Aero Hirsch
    Thumbs Up:   0

    Saab 9-4X evap purge valve error P0496

    I got this error for sometime, APC gauge not working, and i feel there is a problem with performance and bahavior. As i understood this is pretty common on 9-4x and on other v6 cars. Will changing the valve help? What is actuall and correct part number



    Is 12593761 correct part number?

    0 Not allowed!
    Last edited by kurwa311; 20 August 2016 at 08:24.

  2. #2
    Saab Enthusiast
    Join Date
    25 Feb 2012
    Posts
    92
    Thumbs Up:   0
    I think that was the error I got and ordered a replacement part from Amazon:

    ACDelco 214-2137 GM Original Equipment Vapor Canister Vent Valve
    https://www.amazon.com/ACDelco-214-2.../dp/B002E58QNM

    It took a day or two for the code to clear and about 30 minutes or less to install.

    0 Not allowed!
    Last edited by nordwulf; 24 August 2016 at 12:40. Reason: updated link

  3. #3
    Saab Enthusiast
    Join Date
    26 Dec 2011
    Location
    Russia
    Posts
    168
    Saab(s)
    88' 9000 2.0i, 05' 9-5 Aero 345HP, 11' 9-4X Aero Hirsch
    Thumbs Up:   0
    my part is incorrect?

    0 Not allowed!

  4. #4
    Saab Enthusiast
    Join Date
    25 Feb 2012
    Posts
    92
    Thumbs Up:   0
    Quote Originally Posted by kurwa311 View Post
    my part is incorrect?
    I'm not sure, sometimes the same part as two different numbers and I can not remember for sure 100% if this is the exact code I got.

    I have the 3.0 engine and the part fits behind the throttle body toward the firewall (making it slightly harder to install). Since it only cost $25 I purchased it and it solved the problem-- it seems like it's the same problem you have but I don't know if the 2.8 engine uses a different part. Amazon says my part doesn't fit the 2.8L, so if that's what you have that's probably the right part you listed is the right one. They look similar but includes a 2" bolt that used to mount it.

    Don't mean to steer you wrong . . . just reporting my experience.

    0 Not allowed!

 

 

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
All times are GMT. The time now is 13:09.
Powered by vBulletin® Version 4.2.5
Copyright © 2019 vBulletin Solutions Inc. All rights reserved.