Welcome to the world of Saab ! Register
Results 1 to 3 of 3
  1. #1

    Join Date
    12 Jan 2019
    Location
    Dallas, TX
    Posts
    2
    Saab(s)
    2006 9-5
    Thumbs Up:   0

    Car won't start a week after oil change but oil seems fine. . .CPS?

    2006 Saab 9-5, 86,000 miles

    So.. on Monday my daughter got her oil changed and all seemed fine. She headed back to college on Thursday and called me when she arrived that she noticed the yellow engine light was on. Her drive back to college was 3 hours. I had her check the oil and it was fine (looked clean and was full via dipstick). She did an errand or two last night. . .seemed fine though it was "running rough". She called me this morning and said that the car wouldn't start and it looked like the check engine light was on. I had her turn it over with me listening on the phone and it doesn't sound like a battery/starter issue as the engine is turning over it just won't start. Also had her charge the battery to be sure.

    What do you guys think is going on? Seems odd this happens after an oil change but then why does the oil level seem fine? Given that she is in college and I am here not much I can do personally to check it and there don't seem to be any/many Saab repair shops in College Station, TX.

    BTW, this seems to match most of her symptoms - https://www.doityourself.com/stry/7-...ilure-symptoms
    Crankshaft position sensor.

    Any thoughts?

    0 Not allowed!

  2. #2
    Frank
    Administrator nordwulf's Avatar
    Join Date
    30 Jul 2010
    Location
    NW Michigan, USA
    Posts
    7,665
    Saab(s)
    previous: 2006 9-3, 2001-06 9-5, 2011 9-4X
    Thumbs Up:   82
    Using an OBDII code reader will give you more information about the engine light. The oil change and this non-starting issue are most likely not related at all.

    Any garage should be able to read the code or perhaps she can try to borrow one from an auto parts store. The latter is probably the easiest as the car is not running.

    1 Not allowed!

  3. #3

    Join Date
    12 Jan 2019
    Location
    Dallas, TX
    Posts
    2
    Saab(s)
    2006 9-5
    Thumbs Up:   0
    Thanks. . .I have a friend with a tool who is able to head over tomorrow and read it.

    0 Not allowed!

 

 

Similar Threads

  1. Help - Sputtering on cold start, runs fine after that
    By Kazamario in forum Saab 9-5 (1998-2009)
    Replies: 34
    Last Post: 30 May 2017, 17:22
  2. Replies: 7
    Last Post: 28 January 2016, 19:37
  3. Replies: 2
    Last Post: 23 December 2014, 02:12
  4. 2007 9-3 2.0t - faltered, died 2x upon ignition / otherwise fine
    By fourthliner in forum Saab 9-3 (2003-2014)
    Replies: 4
    Last Post: 11 March 2014, 14:22
  5. Bargin of the Week.
    By Lex Andrews in forum Tech Talk
    Replies: 2
    Last Post: 30 June 2012, 16:15

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
All times are GMT. The time now is 19:30.
Powered by vBulletin® Version 4.2.5
Copyright © 2019 vBulletin Solutions Inc. All rights reserved.