Welcome to the world of Saab ! Register
Results 1 to 4 of 4
  1. #1

    Join Date
    29 May 2019
    Location
    Asheville, NC
    Posts
    3
    Saab(s)
    2005 9-5 Arc
    Thumbs Up:   0

    No OBD2 Communication

    2005 9-5 Arc.
    I've got power but no communication with T2 or standard OBD scanner.
    Checked pins at Port and they all looked decent but I replaced the port anyway, so it would be new.
    Still nothing.

    Everything else seems to work fine electronically, starts and runs well, but I'm getting CEL and I don't know exactly what for.

    I did search but only found posts to no power at Port or bad port issues.


    Any input/ideas anyone may have would be greatly appreciated!

    0 Not allowed!

  2. #2
    Saab Owner Digger's Avatar
    Join Date
    28 Oct 2016
    Location
    Minneapolis Minnesota
    Posts
    947
    Saab(s)
    2006 9-3 2.0t SportCombi
    Thumbs Up:   142
    This is an across the board all cars problem and when you have power at the connector and no communication it is usually the engine controller. Pull the battery cable and check the plug connections and cables to the ECM and try again.

    1 Not allowed!

  3. #3

    Join Date
    29 May 2019
    Location
    Asheville, NC
    Posts
    3
    Saab(s)
    2005 9-5 Arc
    Thumbs Up:   0
    Quote Originally Posted by Digger View Post
    This is an across the board all cars problem and when you have power at the connector and no communication it is usually the engine controller. Pull the battery cable and check the plug connections and cables to the ECM and try again.
    Will do. I feel like I've tried all the "known" issues but I will certainly try that out specifically.
    I did find some troubleshooting trees in WIS and I've going through those steps, as well.

    Thanks!

    0 Not allowed!

  4. #4

    Join Date
    29 May 2019
    Location
    Asheville, NC
    Posts
    3
    Saab(s)
    2005 9-5 Arc
    Thumbs Up:   0
    Quote Originally Posted by harveyspecter View Post
    Have you figure out the issue yet? Hope you can fix it soon.
    Sure did!
    After a very long time I basically started from scratch it realized that while all the pins were strongly in position in the port, one of them (blue) was in the wrong position.

    I'm pretty sure I'm down to only having in intermittently failing ignition switch now.

    I've got a used one and when I get back home next week I'll get it back together and hopefully that will be it!

    0 Not allowed!

 

 

Similar Threads

  1. Bus and diagnostics communication - Saab 9-3 (2003-2006)
    By SaabWorld in forum Diagnostics and documentation
    Replies: 5
    Last Post: 08 May 2016, 17:16
  2. OBD2/Tech2 in 1996 Saab 9000?
    By zmhcreative in forum Saab 9000 (1985-1998)
    Replies: 0
    Last Post: 22 July 2013, 15:20
  3. Diagnostic scanner OBD2 recommendations
    By neilledgar in forum Tutorials and guides
    Replies: 11
    Last Post: 02 May 2013, 14:27
  4. OBD2 scanner software for DPF status
    By dave08 in forum Saab 9-3 (2003-2014)
    Replies: 0
    Last Post: 29 July 2012, 22:21

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
All times are GMT. The time now is 18:35.
Powered by vBulletin® Version 4.2.5
Copyright © 2019 vBulletin Solutions Inc. All rights reserved.