Welcome to the world of Saab ! Register
Results 1 to 10 of 10
  1. #1
    Saab Fan
    Join Date
    14 Jun 2019
    Location
    kirkcudbright, scotland
    Posts
    16
    Saab(s)
    2004 9-3 2.2tid arc
    Thumbs Up:   0

    EGR fault

    Ok i'm wondering if the motor on an EGR can fail because i'm getting running problems, if i connect plumbing wrong the wastegate doesn't function nor does the EGR mechanism when revved and the car will drive fine like that just sluggish and in 4th gear at about 2500 revs it loses power with error code p0244 but if i connect pipes to the pierberg solenoid near front correctly the wastegate pulls down when car is started and goes up and down as car is revved and as for the EGR valve if you push mechanism by hand its smooth but when started it jumps around then stays about half open then when you rev engine it jumps open then jerks closed then slowly goes back to half way open then eventually closes and if you touch accelerator it does it all again, sometimes it does that by itself so i am wondering if the motors can fail/play up also i have removed the EGR and the throttle housing and cleaned all of it and i have replaced vacuum hoses and changed MAP sensor

    0 Not allowed!

  2. #2
    Saab Owner Digger's Avatar
    Join Date
    28 Oct 2016
    Location
    Minneapolis Minnesota
    Posts
    947
    Saab(s)
    2006 9-3 2.0t SportCombi
    Thumbs Up:   142
    Vacuum or electric, sticky EGR valves happen on all makes of cars and like the idle air motor, if cleaning doesn't get it working its time to replace. As you're not paying a mechanic by the hour to do this, give it a couple of cleanings and a couple of test runs before you replace.

    0 Not allowed!

  3. #3
    Saab Fan
    Join Date
    14 Jun 2019
    Location
    kirkcudbright, scotland
    Posts
    16
    Saab(s)
    2004 9-3 2.2tid arc
    Thumbs Up:   0
    Thanks bud cleaning it made a marginal improvement but not much the lurching isnt as violent but its still not really drivable, I mean if you move mechanism with figures it moves and springs back freely but if I connect pipes to solenoid so wastegate gets vacuum on start up the valve mechanism jumps around then settles on half open then if you touch accelerator it jumps closed then open then eventually settles back to half open or closed very occasionally or vibrates, I've tried cleaning it the mechanism is clean as is the valve inside so is throttle housing but it doesn't change

    0 Not allowed!

  4. #4
    Saab Fan
    Join Date
    14 Jun 2019
    Location
    kirkcudbright, scotland
    Posts
    16
    Saab(s)
    2004 9-3 2.2tid arc
    Thumbs Up:   0
    Were is the idle air valve on the 2.2 tid

    0 Not allowed!

  5. #5
    Saab Owner Digger's Avatar
    Join Date
    28 Oct 2016
    Location
    Minneapolis Minnesota
    Posts
    947
    Saab(s)
    2006 9-3 2.0t SportCombi
    Thumbs Up:   142
    The IAC, idle air isn't your problem, but it is a motor driven air valve found on throttle bodies and a sticky one causes surging at idle. I used idle air as an example of a part that causes problems and is almost impossible to get fully clean without pulling and going at the shaft and valve seat from both sides. If it has been sticking long enough, no amount of cleaning will get it working again.

    0 Not allowed!

  6. #6
    Saab Fan
    Join Date
    14 Jun 2019
    Location
    kirkcudbright, scotland
    Posts
    16
    Saab(s)
    2004 9-3 2.2tid arc
    Thumbs Up:   0
    Ahh got you bud, well I'm sure it's the egr, I've configured pipes at moment so it and wastegate aren't working so its drinkable but under heavy load like going up hill if its steep there is a lot of black smoke and it slows to a crawl and if configured so egr and wastegate are working its undrivable from the start with egr mechanism quiet erratic and not closing after foot off accelerator do I'm 90% sure its cause

    0 Not allowed!

  7. #7
    Saab Fan
    Join Date
    14 Jun 2019
    Location
    kirkcudbright, scotland
    Posts
    16
    Saab(s)
    2004 9-3 2.2tid arc
    Thumbs Up:   0
    Took valve off again took end off the motor seemed free moving and I cleaned the rod and throttle housing end agsin it seemed better but not great do I dont think it will get better with that 1, there was also an underlying rasping noise but I think that cause it sits half open also the map sensor I fitted 2 days ago was choked to hell

    0 Not allowed!

  8. #8
    Saab Fan
    Join Date
    14 Jun 2019
    Location
    kirkcudbright, scotland
    Posts
    16
    Saab(s)
    2004 9-3 2.2tid arc
    Thumbs Up:   0
    Well I've tried another egr valve of a younger lower mileage car and another solenoid which has pipes connected from air tank to swirl flap above egr and exactly the same but if I leave it plumbed for egr and wastegate to work and disconnect maf sensor it all works, mo smoke at all but in limp mode

    0 Not allowed!

  9. #9
    Saab Fan
    Join Date
    14 Jun 2019
    Location
    kirkcudbright, scotland
    Posts
    16
    Saab(s)
    2004 9-3 2.2tid arc
    Thumbs Up:   0
    ok i tried a brand new bosch maf and it run like a bag of shite again but if disconnected runs fine just in limp mode, is the wastegate ment to pull in when car starts and it only plays up when plastic solenoid at front is connected with input at bottom and output on side, if i switch it around wastegate nor egr do anything but it runs fine just a little smoky was just thinking aswell it sounds when the maf is disconnected as if its sucking air hard and noise stops when its connected

    0 Not allowed!

  10. #10
    Saab Fan
    Join Date
    14 Jun 2019
    Location
    kirkcudbright, scotland
    Posts
    16
    Saab(s)
    2004 9-3 2.2tid arc
    Thumbs Up:   0
    Little update, I've noticed the valve at end of inlet manifold on right does nothing I even used a hand vacuum gauge and it doesn't move, can it be cause of problems

    0 Not allowed!

 

 

Similar Threads

  1. Fault reporting
    By GeoffR in forum Tech Talk
    Replies: 2
    Last Post: 27 April 2019, 08:45
  2. Service ESP fault
    By gregplowman in forum Saab 9-5 (2010-2012)
    Replies: 6
    Last Post: 01 August 2015, 16:49
  3. Fault codes
    By frisp in forum Saab 9-5 (1998-2009)
    Replies: 8
    Last Post: 20 July 2015, 10:43
  4. ACC fault codes
    By rjl01wgn in forum Saab 9-5 (1998-2009)
    Replies: 4
    Last Post: 23 February 2015, 15:01

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
All times are GMT. The time now is 15:48.
Powered by vBulletin® Version 4.2.5
Copyright © 2019 vBulletin Solutions Inc. All rights reserved.