Welcome to the world of Saab ! Register
Results 1 to 3 of 3
  1. #1
    Scott Gowdy
    Saab Fan Jimmy Neutron's Avatar
    Join Date
    01 Mar 2016
    Location
    Wilmington, NC, USA
    Posts
    5
    Saab(s)
    2003 9-5 Aero 2.3T
    Thumbs Up:   0

    P1530 and Limp Home Mode Frustration

    My 2003 9-5 Aero randomly throws a P1530 error code and the throttle body trips into Limp Home Mode. My garage has replaced the throttle body 3 times with new Hella TBs and it will run great for about a week or two, and then trip into Limp Home Mode again with the P1530 code. I can reset it easily, and then it will run great until the next random trip (days to weeks later). Could another component be causing this sequence of events? Crankshaft Position Sensor? ECM? DIC? I did replace the fuel pump just prior to all these problems with the Throttle Body. Could it be a faulty fuel pump? The DIC was replaced about 2 years ago. Any advice would be appreciated!

    0 Not allowed!

  2. #2
    Scott Gowdy
    Saab Fan Jimmy Neutron's Avatar
    Join Date
    01 Mar 2016
    Location
    Wilmington, NC, USA
    Posts
    5
    Saab(s)
    2003 9-5 Aero 2.3T
    Thumbs Up:   0
    Tripped again...this time a P1260 code.

    0 Not allowed!

  3. #3

    Join Date
    02 Oct 2017
    Location
    Ciudad Autónoma de Buenos Aires, Argentina
    Posts
    1
    Saab(s)
    SAAB 9000 CSE 2.3T 1994
    Thumbs Up:   0
    Hello!

    As I read before, and if I'm recall properly, maybe you should try resetting the mechanical TB Limp Home Mode, is relatively well explained in some YouTube videos, and reset the ECU pulling the fuse #17 for a while to clean the fault code.

    Additionally, I think that checking the TB wiring could help, just to be sure that there aren't a short circuit in the harnesses. Three throttle bodies in a short period of time is not very common, IMHO.

    Sorry if i misspelled something, I'm not an English speaker, and of course, feel free to correct me if i said something wrong.

    I hope that my comment helps, good luck!

    Regards!

    Enviado desde mi Redmi Note 7 mediante Tapatalk

    0 Not allowed!

 

 

Similar Threads

  1. limp mode
    By drewrobson in forum Saab 9-3 (2003-2014)
    Replies: 13
    Last Post: 01 June 2018, 20:28
  2. Replies: 3
    Last Post: 17 June 2014, 11:04
  3. auto transmission goes into limp mode home
    By blackwiddow in forum Saab 900 and 9-3 (1994-2003)
    Replies: 3
    Last Post: 25 July 2013, 13:09
  4. feels like "limp home mode" after reseting it!?
    By dannydoh in forum Saab 9-5 (1998-2009)
    Replies: 1
    Last Post: 11 July 2013, 16:08

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
All times are GMT. The time now is 12:34.
Powered by vBulletin® Version 4.2.5
Copyright © 2020 vBulletin Solutions Inc. All rights reserved.