Welcome to the world of Saab ! Register
Results 1 to 2 of 2
  1. #1
    Saab Fan
    Join Date
    17 Jan 2018
    Location
    Queensland Australia
    Posts
    17
    Saab(s)
    9-3 ARC 05 auto
    Thumbs Up:   0

    Another 9-3 codes thread... Australian car

    I did a search for my issue and found similar threads, but from 2012, 2013 and 2017... and rather than resurrect an old thread that didn't answer the questions, I have decided to start a new thread.

    My 2005 9-3 ARC auto has a solid yellow engine light. It drives fine and seems powerful and smooth enough... and is doing 8.1L per 100km... so, not limping. It pulls strongly and the turbo needle goes to the end of the white, nearly to the red if I stand on it... I am happy with the performance, it starts fine, idles nicely... happy days!

    When I first got the car, the yellow engine light was on, I googled 9-3 issues and replaced the fuel cap... after about half an hour's driving, the light went out. The next day, however, the light came back on... solid yellow.

    So, I plugged in a UBD11 scan tool and it came up with 6 codes:

    PO201
    cylinder 1 injector A circuit

    PO202
    cylinder 2 injector A circuit

    PO203
    cylinder 3 injector A circuit

    PO204
    cylinder 4 injector A circuit

    PO245
    Turbocharger/supercharger
    Wastegate Actuator A Low

    PO246
    Turbocharger/supercharger
    Wastegate Actuator A High

    So, in my research on the other threads, code PO245 suggests a failing ecm.... however both of my scan tools bought up the same codes and it seems to me that the PO245 is to do with a wastegate issue, rather than an ecm failure? As I said, the car is running perfectly, it is not using alot of fuel, it doesn't smell of fuel, no black smoke to suggest it is running rich, starts with no throttle... plenty of go. Also, why would the yellow light have gone out after I replaced the gas cap and filled the tank.... only to come back on the next day... but again, absolutely no running issues?

    I am running 98 octane fuel, I put some injector cleaner (nulon) in the fuel tank

    Should I cancel the codes and see if they come back on? Should I leave it be, as it is running so beautifully? Or should I start saving for a replacement ecm?

    Any advice gratefully accepted

    0 Not allowed!

  2. #2

    Join Date
    15 Dec 2020
    Location
    Lancashire uk
    Posts
    1
    Saab(s)
    93 ttid
    Thumbs Up:   0
    Did you solve your problem as mine is doing very much the same.

    0 Not allowed!

 

 

Similar Threads

  1. The oil thread
    By JonV in forum Tech Talk
    Replies: 66
    Last Post: 23 June 2021, 18:04
  2. Australian Stereo Update A306
    By hepklep in forum Saab 9-5 (2010-2012)
    Replies: 3
    Last Post: 28 May 2020, 11:08
  3. 9-5 Aero Spring Code Reference Thread - Add Your AERO Codes
    By Burnsside42 in forum Diagnostics and documentation
    Replies: 2
    Last Post: 27 August 2019, 16:30
  4. Oil thread
    By AnthonySaab in forum Saab 900 and 9-3 (1994-2003)
    Replies: 4
    Last Post: 18 April 2014, 19:45
  5. Where did the thread go?
    By Wasaabi in forum The Clubhouse
    Replies: 12
    Last Post: 26 August 2010, 20:23

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
All times are GMT. The time now is 19:06.
Powered by vBulletin® Version 4.2.5
Copyright © 2021 vBulletin Solutions Inc. All rights reserved.