Welcome to the world of Saab ! Register
Results 1 to 2 of 2
  1. #1

    Join Date
    12 Nov 2020
    Location
    UK
    Posts
    1
    Saab(s)
    2008 93 1.9TTiD Sportwagon
    Thumbs Up:   0

    2008 93 1.9TTiD Starting issie

    Hi all,
    I've had a starting issue with my 1.9TTiD ever since I bought it 2 years ago. It's 2008 model.
    Basically it seems to occur when the car has been left for a few days. I'll go to start the car, wait for the glow plug light and then start it. It'll turn over at a normal speed just won't start. I do this 3 or 4 times and then give up. The strange thing is, when I come back to it around 10 minutes later it starts first time.
    When it first happened I assumed it was the battery, because when it happens jump starting from another car works. However I got a new one and nothing changed of course. It happens maybe once every 3 weeks. Maybe more when it gets a bit colder during winter.
    Glow plugs all measure 0.7 Ohms.
    The other thing I've noticed is that the glow plug light on my dash never seems to be illuminated for a particularly long time... I was under the impression it was supposed to illuminate for 3 seconds at normal ambient temperature but even when it's dead cold it flashes on for about half a second at best.
    When I've tried to measure voltage at the glow plug connectors I haven't been able to measure anything at all.
    Any help or suggestions for debugging would be fantastic!

    0 Not allowed!

  2. #2
    Saab Fan
    Join Date
    24 Jan 2020
    Location
    Manchester, UK
    Posts
    9
    Saab(s)
    SAAB 9-3 TTID
    Thumbs Up:   0
    I had same issue with a VectraC, fitted new battery no luck with that, I was advised by a Vectra C forum member to change the starter motor I was a little sceptical as the starter sounded fine. I changed it and left the car overnight so I knew it was cold, bingo it started first time. Not saying it would cure your issue but just passing on my experience.

    Sent from my CLT-L29 using Tapatalk

    0 Not allowed!

 

 

Similar Threads

  1. 900 suddenly not starting
    By scootermac in forum Saab 900 (1979-1994)
    Replies: 2
    Last Post: 04 January 2016, 05:32
  2. Starting problem
    By Arkadi in forum Saab 9-5 (2010-2012)
    Replies: 4
    Last Post: 15 December 2015, 05:54
  3. Hard Starting Cold With Engine Misfire and Low Compression 2007-2008 9-3 B207
    By Burnsside42 in forum Diagnostics and documentation
    Replies: 50
    Last Post: 05 May 2015, 00:32
  4. not starting
    By bob in forum Saab 9-5 (1998-2009)
    Replies: 1
    Last Post: 08 April 2015, 13:00
  5. Warm engine, hard starting; cold engine, easy starting
    By Badwolf in forum Saab 900 (1979-1994)
    Replies: 23
    Last Post: 17 January 2014, 18:39

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
All times are GMT. The time now is 09:20.
Powered by vBulletin® Version 4.2.5
Copyright © 2021 vBulletin Solutions Inc. All rights reserved.