Welcome to the world of Saab ! Register
Results 1 to 2 of 2
  1. #1

    Join Date
    17 Nov 2020
    Location
    Sweden
    Posts
    2
    Saab(s)
    SAAB 9-3 VECTOR SPORTCOM
    Thumbs Up:   0

    Soundsystem - Amp2 Help

    Hi
    Is there anyone out there who has experience repairing the AMP2 in the ICM3 stereo sound system?
    Trying to get a circuit diagram or some help to localize the problem!!

    And the probem is - It's dead. Red optosignal comes in to the unit and I get a transmit red signal for 15 sec. Then it will turn black.
    Of course, I have no sound and no image on the screen.
    I have 12V power in the socket.

    And I purchased another unit ( second hand ) that worked for 2 weeks(!) That unit is complete dead with no red signal transmitted.

    I need help! Thank You!
    Attached Images Attached Images  

    0 Not allowed!

  2. #2

    Join Date
    17 Nov 2020
    Location
    Sweden
    Posts
    2
    Saab(s)
    SAAB 9-3 VECTOR SPORTCOM
    Thumbs Up:   0
    This AMP2 was ( also ) dead after a battery change.
    (I have read at least two post with the same issue now )

    0 Not allowed!

 

 

Similar Threads

  1. AMP2 Failure / Radio not working
    By m3245 in forum Saab 9-3 (2003-2014)
    Replies: 8
    Last Post: 24 August 2019, 20:36
  2. Upgrade soundsystem in 93 ss 2008
    By alesto in forum Saab 9-3 (2003-2014)
    Replies: 3
    Last Post: 06 October 2012, 01:03

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
All times are GMT. The time now is 20:19.
Powered by vBulletin® Version 4.2.5
Copyright © 2020 vBulletin Solutions Inc. All rights reserved.